GeoCat Bridge compatibility with GeoServer 2.13.4 and earlier

Both Bridge for ArcMap v3.2+ and Bridge for QGIS 4.1+ use GeoPackages (an OGC standard data format) to upload and store data on GeoServer.

Unfortunately, there is an issue with GeoServer 2.13.4 (and earlier) with GeoPackage support. If you are using GeoServer 2.13.4 or earlier, you may see an error in your GeoServer logs like this:

Caused by: java.lang.ArrayIndexOutOfBoundsException: Can handle 5 attributes only, index is 5


ERROR [geotools.rendering] - The specified mark file://<file>.svg was not found!

To solve this, you will have to upgrade to GeoServer 2.14.0 or later.


  • GeoServer, ArcMap, QGIS, GeoPackage
  • 2 Users Found This Useful
Was this answer helpful?

Related Articles

Connecting to GeoServer 2.14 or older using GeoCat Bridge for ArcMap

It's not possible to connect to GeoServer 2.14 with the default settings of the GeoCat Bridge for...