Bridge 4 compatibility with Geoserver 2.13.4 and before

Bridge 4 uses GeoPackages (an OGC standard data format) to store data in Geoserver.

Unfortunately, there is an issue with Geoserver 2.13.4 (and earlier) with GeoPackage support.  If you are using Geoserver 2.13.4 or earlier, you may see an error in your Geoserver logs like this;

Caused by: java.lang.ArrayIndexOutOfBoundsException: Can handle 5 attributes only, index is 5

OR

ERROR [geotools.rendering] - The specified mark file://<file>.svg was not found!

Solution - upgrade to Geoserver 2.14.0 or later.

 

  • 1 Users Found This Useful
Was this answer helpful?

Related Articles

Bridge 3 ArcMap connection to GeoServer 2.14

It's not possible to connect to GeoServer 2.14 with the default settings of GeoCat Bridge ArcMap...